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This user’s manual contains useful information about the precautions, functions, and operating 
procedures of the X-Wirepuller program, which is available at the following website:
 https://tmi.yokogawa.com/library/
To ensure correct use, please read this manual thoroughly during operation.
After reading the manual, keep it in a convenient location for quick reference whenever a question arises 
during operation.
For information about the handling precautions, functions, and operating procedures of the DL series 
digital oscilloscopes, and the handling and operating procedures of Windows, see the manuals that 
accompany the particular instrument you are using.

Notes
•  The contents of this manual are subject to change without prior notice as a result of continuing 

improvements to the software's performance and functions. The figures given in this manual may 
differ from those that actually appear on your screen.

•  Every effort has been made in the preparation of this manual to ensure the accuracy of its contents. 
However, should you have any questions or find any errors, please contact your nearest YOKOGAWA 
dealer.

•  Copying or reproducing all or any part of the contents of this manual without the permission of 
YOKOGAWA is strictly prohibited.

Trademarks
•  Microsoft, Internet Explorer, Windows, Windows 8, Windows 8.1, and Windows 10 are either 

registered trademarks or trademarks of Microsoft Corporation in the United States and/or other 
countries.

•  Adobe, Acrobat, and PostScript are either registered trademarks or trademarks of Adobe Systems 
incorporated.

• In this manual, the ® and TM symbols do not accompany their respective registered trademark or 
trademark names.

•  Other company and product names are trademarks or registered trademarks of their respective 
holders.

Revisions
1st Edition:  September 2005
2nd Edition:  January 2009
3rd Edition:  April 2009
4th Edition:  October 2009
5th Edition:  July 2010
6th Edition:  June 2011
7th Edition:  November 2012
8th Edition:  November 2018
9th Edition:  September 2020

 

9th Edition: September 2020 (YMI)
All Rights Reserved, Copyright © 2005 Yokogawa Electric Corporation
All Rights Reserved, Copyright © 2010 Yokogawa Test & Measurement Corporation
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Software License Agreement

Yokogawa Test & Measurement Corporation
X-Wirepuller Software License Agreement

 Important: Read the following terms and conditions carefully.
By installing or using X-Wirepuller (hereafter referred to as This Software), you accept all terms and conditions in this 
license agreement. All rights pertaining to the software—including property rights, ownership rights, and intellectual 
property rights—belong to Yokogawa Test & Measurement Corporation (hereafter referred to as YOKOGAWA), 
YOKOGAWA’s affiliated company, or original proprietor that has granted rights for licensing the software to customers 
based on this agreement (hereafter referred to as the original proprietor). Customers do not have any other rights other 
than the right to use the software in accordance with this agreement. This Software is provided for free on an “as-
is” basis. You are liable for all responsibilities arising from using This Software and all responsibilities arising from 
referring to This Software. Regardless of whether This Software is used, you are entirely responsible for its quality, 
technical requirements, and regulatory requirements or regulatory conformance.

This software may contain open source software (hereafter referred to as OSS) in addition to the software that YOKOGAWA 
holds the rights to or the software that YOKOGAWA has been authorized to license. License terms appropriate for each OSS 
component are applicable in place of the terms of this license. If there is a discrepancy between the terms of the OSS license 
and the terms of this license, the license terms of the corresponding OSS take precedence.

Article 1: No Warranty

1. This Software is provided for free on an “as-is” basis without any warranty. YOKOGAWA will not be liable for defects or 
non-fulfillment of any kind. YOKOGAWA gives no guarantee that (1) the functions included in This Software will meet your 
requirements or your customer’s requirements, (2) This Software will run without errors (e.g., bugs) or interruptions, (3) the 
defects and errors (e.g., bugs) in This Software will be corrected, (4) there will be no inconsistencies, mutual interference, 
or other effects between This Software and other software, (5) This Software or the product of This Software is correct, 
accurate, reliable, or up-to-date, (6) This Software is compatible with specific software required for This Software to run, or 
(7) This Software will not be accessed illegally or attacked through its vulnerability or the like.

2. YOKOGAWA is not always able to repair defects in or respond to questions or inquiries about This Software. Further, the 
contents of the software are subject to change without prior notice as a result of continuing improvements to the software’s 
performance and functions.

Article 2: Your Responsibilities
The following acts are prohibited unless YOKOGAWA agrees or stipulates otherwise in writing.

(1) Duplicate This Software.
(2) Sell, lend, distribute, transfer, pledge, or re-license This Software or the right to use This Software or transmit it to the 

public or make it transmittable.
(3) Share This Software in a virtual environment (regardless of the technical method such as physical computers, virtual 

computers, etc.).
(4) Convert or copy This Software to any human readable form (e.g., source program) by dumping, reverse assembling, 

reverse compiling, reverse engineering, or the like. Modify or attempt to modify This Software into another form by 
correcting or translating into another language.

(5) Remove or attempt to remove the protection mechanism (copy protection) used on or added to This Software.
(6) Delete the copyright, trademarks, logos, and other indications displayed on This Software.
(7) Unless YOKOGAWA has agreed otherwise in writing, create derivative software or other computer programs or allow the 

creation of such works.

Article 3: Restriction on Use

1. Unless a separate written agreement is drawn between you and YOKOGAWA, This Software is not designed, manufactured, 
or licensed to be used for aircraft operation, ship navigation, or the planning, construction, maintenance, operation, or use of 
on-ground support equipment or nuclear facilities

2. If you are using This Software for a purpose described in the previous clause, YOKOGAWA will not be held liable for any 
claim or damage incurred as a result of using This Software, and you will take full responsibility in resolving the issue.

Article 4: Limitation of Liability
YOKOGAWA will not be held liable for any damages incurred in relation to This Software.

Article 5: Court with Jurisdiction
Should a dispute arise as a result of using This Software or in regards to this license agreement, both parties agree to 
discuss the issue in good faith. If an agreement cannot be reached, the Tokyo District Court shall be the exclusive agreement 
jurisdictional court of the first hearing.
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1. Product Overview

Functions
XWirepuller enables the DL9000 series including MSO models, SB5000 series, DLM2000 series, 
DLM3000 series, DLM4000 series, DL6000/DLM6000 series, DL850 series, and DL350 series to be 
controlled from your PC via the Ethernet, USB, or GP-IB interface.
When the software program starts, the front panel image of the connected the DL9000 series, SB5000 
series, DLM2000 series, DLM3000 series, DLM4000 series, DLM5000 series, DL6000/DLM6000 
series appears on the monitor of your PC. You can control these instruments from your PC with the 
mouse to simulate operations using the front panel keys of the instrument.

Saving Screen Images
 Saves the screen image data displayed on your PC in BMP or PNG format. The image of display 

section of control window is copied to the clipboard.

Selecting the Control Window Size
 You can select the size of the control window that is displayed on your PC from the choices below. 

When the display resolution of the PC is small, the control window can be displayed reduced in 
size.
• Larger:  Displays the screen image of the DL using the same number of pixels as 

the number of pixels of the entire screen of the connected instrument.
• Standard:  Displays the screen image of the DL using 75% of the number of pixels of the 

entire screen of the connected instrument.
• Smaller:  Displays the screen image of the DL using 50% of the number of pixels of the 

entire screen of the connected instrument.
• Full screen: Displays the screen image of the DL with a full-screen mode.

Selecting the Display Update Rate
 You can select the display update rate of the DL screen image from the following.
 However, the actual display update rate may be slower than the specified update rate depending on 

the network transmission system or the amount of communication load.
  100 ms to 10 s 

Updating the Screen
 The screen image of the DL can be forcibly updated. This is done when the display update rate is 

set to a low value or when the display update is paused.

Pausing Display Update Operation
 Pauses the display update operation.
 Pausing the display update operation improves the response of the software program such as when 

turning ON/OFF numerous items at once or when entering values from a keyboard.
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Control Screen
The control screen differs depending on the connected DL. Here, the control screens of the DL9000 
series, SB5000 series, and DLM 2000 series are shown as examples.

For DL9000 series/SB5000 series Digital Oscilloscopes

  Disconnect

Disconnect

For DLM2000 Series Digital Oscilloscopes

  

Disconnect

1. Product Overview
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PC System Requirements
Operating System
Microsoft Windows 8, Windows 8.1, and Windows 10

PC Hardware
CPU: Core 2 Duo, 2 GHz or better
Memory: 1 GB or more (2GB recommended)
Space available on HDD: Free space equaling 2 GB + the size of files to be loaded

Peripherals
Display: XGA or higher (Colors: 65536 or more)
Drive: CD-ROM drive, mouse, and printer
Communication interface: GP-IB1/USB1/Ethernet

 GP-IB Board or PCMCIA Card GP-IB board made by National Instruments Corporation or PCMCIA 
card2

1:  To use the USB interface, a dedicated USB driver is required.
2:  The operation of the PCMCIA-GPIB card is not guaranteed on Windows 8, Windows 8.1, and 

Windows 10.

Interface supported by Models
Models GP-IB USB Ethernet

DL9040/DL9140/DL9240 series
(firmware version 1.64 or later) ✓ ✓ ✓

DL9500/DL9700 series
(firmware version 3.20 or later) ✓ ✓ ✓

SB5000 series
(firmware version 4.00 or later) ✓ ✓ ✓

DLM2000 series
(firmware version 1.08 or later) ✓ ✓ ✓1

DLM3000 series ✓ ✓ ✓1

DLM4000 series ✓ ✓ ✓1

DLM5000 series ✓ ✓ ✓1

DL6000/DLM6000 series ✓ ✓ ✓1

DL850 series ✓ ✓ ✓1

DL350 series – ✓ ✓1

 1: Connected with VXI-11

1. Product Overview
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Notes on Using the Software
Precautions Concerning the Use of the Software
• Do not perform operations directly on the DL series digital oscilloscopes while using this software 

program. Doing so can lead to erroneous operation.
• If the standby mode provided on your PC is activated, the operation of the software may not be 

able to continue.
 When using the software, turn OFF the standby mode.
• If you run the software using a NIC interface, the line load is 4 Mbytes/s maximum. Consult your 

network administrator on using the NIC interface.
• If a connection error occurs when connecting to a DL digital oscilloscope, power cycle the DL.
• Do not set the network or communication parameters of the DL series using this software 

program. The connection may be disconnected.
• Do not execute self-tests using this software program.
• Simultaneous connections from multiple PCs to a single DL series digital oscilloscope are not 

allowed.

1. Product Overview
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2. Connection

Controlling the DL Series
Setting the Communication Interface
Set the DL according to the communication interface to be used.
For the setting method, please refer to the instruction manual of the DL.

Starting Software and Setup the Communication Interface
Click the file "XWirepuller.exe" to display the following window.

 

Note
Before creating communication with the DL, make sure that the cable between PC and DL has been correctly 
wired. For the hardware connection between PC and DL, please refer to the communication operation guide 
of your specific instrument.

Create Connection to the DL Instrument
Click File > Connect menu or  Icon, the connect dialog will then open. The predefined connection 
configurations are listed in it as follows.
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Add New Connection Configuration
The connection configuration list is empty at first start. To add new connection configuration to the DL, 
click the Add button. A new device configuration dialog will then open in which users can select the 
variable communication port and setup the corresponding parameters.
Set the communication interface to be used from the menu of the DL.
 For DL9000 series and SB5000 series. 

 SYSTEM > Remote Control > Device
 For DLM2000 series, DLM3000 series, DLM4000 series, DLM5000 series, and DL6000/DLM6000 

series.
  UTILITY > Remote Control > Device
 For DL850 series and DL350 series
  UTILITY > Remote Ctrl > Device

  

GPIB 
Address:  The unique ID of a GPIB device, ranges from 0~30

Ethernet
VXI-11:  The protocol of the instrument via Ethernet
Server:  The IP address or host name of the instrument
Username: The login username for the Remote Control assigned by the instrument (except VIX-11)
Password: The password for the username (except VXI-11)

USB-TMC
Serial:  The serial No. of the instrument

Click the OK button to add new connection configuration into the configuration list. The program will try 
to check the correctness of the configuration, if succeeded, it will display the instrument model name, 
and otherwise it will return an error message and display “unknown” as model name.

Remove Connection Configuration
Click the Remove button to remove a selected connection configuration from the configuration list.

Change Connection Configuration’s Parameters
Click the Property button to change a selected connection configuration’s parameters, a configuration 
property setting dialog will then open which looks same as the new instrument dialog. Change the 
connection configuration’s parameters and click the OK button to save changes.

2. Connection
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Creating / Breaking up Connection
Create Connection to the DL Instrument
Select a defined connection configuration in the configuration list and click the Connect button to 
connect to the DL. (Double click on defined configuration in the list, also can create connection.) 
The program then will try to initialize the communication to the DL with selected configuration. If 
succeeded, the control window for the instrument will be displayed else, an error message will be 
displayed.

Break up Connection
Click File > Disconnect menu or  icon to break up current connection to the DL .

2. Connection
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3. Functions

Operation panel
Click View > Panel menu to display or hide the operation panel.

 

Note
In the following cases, the control screen display cannot be updated: 
• While editing waveform, square, or polygon zones
• During processing of cycle statistics
• During statistical processing of history data

Control Window Size
Click View > Zoom menu to set the control window size.

Larger: Displays the screen image of the DL using the same number of pixels as 
the number of pixels of the entire screen of the connected instrument.

Standard: Displays the screen image of the DL using 75% of the number of pixels of the entire 
screen of the connected instrument.

Smaller: Displays the screen image of the DL using 50% of the number of pixels of the entire 
screen of the connected instrument.
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Full screen display
Click View > Full Screen menu or  icon to display with a full-screen mode.
The full-screen mode ends if the “ESC” key of the personal computer is pushed, and it returns to a 
usual display. 
The full-screen mode or display of the operation panel can be ended by pushing mouse's right button 
while pushing the “CTRL” key to the personal computer.

Updating the Screen
Click View > Update menu or  icon to update the screen image.

Pausing Display Update Operation
Click View > Pause menu or  icon to pause the display update operation.

Display update Interval
Click View > Options menu, the option dialog will open as follows.
The setting ranges of the interval are from 100 ms to 10 s.  

 

Saving Screen Images
Click Tools > Image menu to save the screen image data displayed on your PC in BMP or PNG 
format.

 
Note

ON(8bit) is not selectable with the DLM2000//DLM3000DLM4000/DL850/DL350 series.

Copying the Image to the Clipboard
Click Tools > Copy Image to Clipboard or Copy Image to Clipboard(Reverse). 

Copy Image to Clipboard
The image of display section of control window is copied to the clipboard.

Copy Image to Clipboard(Reverse)
 The image of display section of control window is copied to the clipboard without the background 

color.

3.  Functions
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Two or more DL
Click Window > Cascade menu, all open windows are cascaded.
Moreover, the list of connected DL is displayed in the menu, and the window can be displayed on the 
foremost side by clicking it.

 

Note
When two or more DL are controlled, the connection might be cut by the situatior connected DL and line. 
Please use it by the number that can be connected with stab.

Viewing version information
Click the Help menu, the version of XWirepuller you are currently using is displayed.

3.  Functions
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Control Window Operation
Using the Mouse
The displayed icon and the mouse operation vary depending on where the mouse pointer is located on 
the control window. The following table shows the mouse operation for each icon and the operation of 
the DL series digital oscilloscopes.

For DL9000 series/SB5000 series
Mouse Pointer Position Displayed Icon and 

Mouse Operation
Operation

Operation key

Click operation Same as pressing the operation key

Screen

Click operation
Wheel operation

Same as the mouse operation of the DL series
Same as the mouse operation of the DL series

Area to the left or right of 
the jog shuttle

Click operation
Wheel operation

Same as turning the jog shuttle to the left or right
Same as turning the jog shuttle

Area to the left, right or 
center of the VERTICAL 
SCALE knob

Click operation
Wheel operation

Same as turning the SCALE knob to the left or right
Same as turning the SCALE knob

Click operation Same as pressing the SCALE knob
Area to the left, right or 
center of the VERTICAL 
POSITION knob

Click operation
Wheel operation

Same as turning the POSITION knob to the left or right
Same as turning the POSITION knob

Click operation Same as pressing the POSITION knob
Area to the left or right of 
the T/DIV knob

Click operation
Wheel operation

Same as turning the T/DIV knob to the left or right
Same as turning the T/DIV knob

Area to the left or right of 
the MAG knob

Click operation
Wheel operation

Same as turning the MAG knob to the left or right
Same as turning the MAG knob

3.  Functions
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Example of Mouse Operation
 1. Operation Key Operation

 Click to select Sine.

   

 2. Jog Shuttle Operation
 Click or operate the wheel to set.

   

 3. VERTICAL POSITION Knob Operation
 Push the knob to change FINE mode.

   

 4. T/DIV Knob Operation
 Turn the wheel to change the T/div setting.

   

3.  Functions
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For DLM2000 series, DLM3000 series, DLM4000 series, DLM5000 series, DL6000/
DLM6000 series, DL850 series, DL350 series
Mouse Pointer Position Displayed Icon and 

Mouse Operation
Operation

Operation key

Click operation Same as pressing the operation key
Screen

Screen

Click operation Same as the mouse operation of the DL series

Around the left or right side 
of the jog shuttle

Click operation

Wheel operation

The setting can be changed at a setting resolution of 
1, 10, or 20 times depending on the location of the 
mouse pointer.
Hold down the mouse button to change the setting 
repeatedly.

Same as turning the jog shuttle
Center of POSITION, 
SCALE, TRIGGER LEVEL, 
or ZOOM knob Click operation Same as pushing the corresponding knob.
Around the left, right, or  
bottom of POSITION or  
TRIGGER LEVEL knob

Click operation

Wheel operation

Same as turning the corresponding knob to the left or 
right.
The setting can be changed at a setting resolution of 
1 or 10 times depending on the location of the mouse 
pointer.
If you click in the bottom area where the number 123 
appears, an input box is displayed for direct input of a 
setting value.
Hold down the mouse button to change the setting 
repeatedly.
 
Same as turning the corresponding knob.

Around the left or right 
of SCALE, TIME/DIV, or  
ZOOM knob

Click operation

Wheel operation

Same as turning the corresponding knob to the left or 
right.
The setting can be changed at a setting resolution of 
1 time.
Same as turning the corresponding knob.

Center of the SET key

Click operation Same as pressing the SET key.

Around the left, right, top, 
or bottom of the SET key

Click operation Same as pushing the SET key in the direction of the 
arrow.

3.  Functions
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4. Exiting the Application
Exiting the Application 
Click File > Exit menu or  icon to exit the application.
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