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This user's manual contains useful information about the functions and operating
procedures and lists the handling precautions of the Mask Pattern Editor. To ensure
correct use, please read this manual thoroughly before beginning operation.
After reading the manual, keep it in a convenient location for quick reference whenever a
question arises during operation.

Notes

Trademarks

Revisions

• The contents of this manual are subject to change without prior notice as a result of
continuing improvements to the software's performance and functions. The figures
given in this manual may differ from those that actually appear on your screen.
• Every effort has been made in the preparation of this manual to ensure the accuracy
of its contents. However, should you have any questions or find any errors, please
contact your nearest YOKOGAWA dealer.
• Copying or reproducing all or any part of the contents of this manual without the
permission of Yokogawa Electric Corporation is strictly prohibited.
• This software program supports the following DL Series Oscilloscopes.
DL9000 Series
SB5000 Series
DLM2000 Series
DLM3000 Series
DLM4000 Series
DL6000/DLM6000 Series

• Microsoft, MS-DOS, Windows, Windows 7, Windows 8, Windows 8.1, and Windows
10 are either registered trademarks or trademarks of Microsoft Corporation in the
United States and/or other countries.
• Adobe and Acrobat are trademarks or registered trademarks of Adobe Systems
Incorporated.
• For purposes of this manual, the TM and ® symbols do not accompany their
respective trademark names or registered trademark names.
• Other company and product names are trademarks or registered trademarks of their
respective companies.
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•
•
•

1st Edition:		
2nd Edition:
3rd Edition:
4th Edition:		
5th Edition:		

June 2005
November 2008
October 2009
November 2012
July 2019

5th Edition: July 2019 (YMI)
All Rights Reserved, Copyright © 2005 Yokogawa Electric Corporation
All Rights Reserved, Copyright © 2012 Yokogawa Test & Measurement Corporation
IM B9852UH-01E

i

Software License Agreement
Yokogawa Test & Measurement Corporation

Mask Pattern Editor Software License Agreement
Important: Read the following terms and conditions carefully.

By installing or using Mask Pattern Editor (hereafter referred to as This Software),
you accept all terms and conditions in this license agreement. All rights pertaining
to the software—including property rights, ownership rights, and intellectual
property rights—belong to Yokogawa Test & Measurement Corporation (hereafter
referred to as YOKOGAWA), YOKOGAWA’s affiliated company, or original
proprietor that has granted rights for licensing the software to customers based
on this agreement (hereafter referred to as the original proprietor). Customers do
not have any other rights other than the right to use the software in accordance
with this agreement. This Software is provided for free on an “as-is” basis.
You are liable for all responsibilities arising from using This Software and all
responsibilities arising from referring to This Software. Regardless of whether
This Software is used, you are entirely responsible for its quality, technical
requirements, and regulatory requirements or regulatory conformance.
This software may contain open source software (hereafter referred to as OSS) in
addition to the software that YOKOGAWA holds the rights to or the software that
YOKOGAWA has been authorized to license. License terms appropriate for each OSS
component are applicable in place of the terms of this license. If there is a discrepancy
between the terms of the OSS license and the terms of this license, the license terms of
the corresponding OSS take precedence.
Article 1: No Warranty
1. This Software is provided for free on an “as-is” basis without any warranty.
YOKOGAWA will not be liable for defects or non-fulfillment of any kind. YOKOGAWA
gives no guarantee that (1) the functions included in This Software will meet your
requirements or your customer’s requirements, (2) This Software will run without
errors (e.g., bugs) or interruptions, (3) the defects and errors (e.g., bugs) in This
Software will be corrected, (4) there will be no inconsistencies, mutual interference,
or other effects between This Software and other software, (5) This Software or the
product of This Software is correct, accurate, reliable, or up-to-date, (6) This Software
is compatible with specific software required for This Software to run, or (7) This
Software will not be accessed illegally or attacked through its vulnerability or the like.
2. YOKOGAWA is not always able to repair defects in or respond to questions or
inquiries about This Software. Further, the contents of the software are subject to
change without prior notice as a result of continuing improvements to the software’s
performance and functions.
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Software License Agreement
Article 2: Your Responsibilities
The following acts are prohibited unless YOKOGAWA agrees or stipulates otherwise in
writing.
(1) Duplicate This Software.
(2) Sell, lend, distribute, transfer, pledge, or re-license This Software or the right to use
This Software or transmit it to the public or make it transmittable.
(3) Share This Software in a virtual environment (regardless of the technical method such
as physical computers, virtual computers, etc.).
(4) Convert or copy This Software to any human readable form (e.g., source program)
by dumping, reverse assembling, reverse compiling, reverse engineering, or the
like. Modify or attempt to modify This Software into another form by correcting or
translating into another language.
(5) Remove or attempt to remove the protection mechanism (copy protection) used on or
added to This Software.
(6) Delete the copyright, trademarks, logos, and other indications displayed on This
Software.
(7) Unless YOKOGAWA has agreed otherwise in writing, create derivative software or
other computer programs or allow the creation of such works.
Article 3: Restriction on Use
1. Unless a separate written agreement is drawn between you and YOKOGAWA, This
Software is not designed, manufactured, or licensed to be used for aircraft operation,
ship navigation, or the planning, construction, maintenance, operation, or use of onground support equipment or nuclear facilities.
2. If you are using This Software for a purpose described in the previous clause,
YOKOGAWA will not be held liable for any claim or damage incurred as a result of
using This Software, and you will take full responsibility in resolving the issue.
Article 4: Limitation of Liability
YOKOGAWA will not be held liable for any damages incurred in relation to This Software.
Article 5: Court with Jurisdiction
Should a dispute arise as a result of using This Software or in regards to this license
agreement, both parties agree to discuss the issue in good faith. If an agreement cannot
be reached, the Tokyo District Court shall be the exclusive agreement jurisdictional court
of the first hearing.
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Overview
This software program is used to create mask patterns that are used on the DL Series.
The mask pattern created using this program can be loaded into the DL Series via a
PC card or USB memory and used for mask tests, GO/NO-GO judgements, and history
search.

Elements

Elements are valid during the execution of the DL Series mask test.
The DL Series mask test can execute judgements simultaneously on every four
elements.
This software program can assign the mask patterns that are created to four elements.
When creating or editing the mask pattern, display ON/OFF and lock/unlock can be set
on each element.
In GO/NO-GO judgement and history search, the element settings are ignored, and all of
the patterns are loaded.

Load and Saving Files

The mask patterns that you create can be saved. You can also load a mask pattern that
you created earlier and edit it.
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PC System Requirements
PC Hardware

A personal computer (PC) is required that is running Windows 7, Windows 8, Windows 8.1,
or Windows 10 having a Core i CPU running at 3.3 GHz or faster, with 2 GB or more of
memory.

Operating System (OS)

Mask Pattern Editor requires Windows 7, Windows 8, Windows 8.1, and Windows 10.

Display

SVGA or higher (XGA or higher recommended)

Colors

256 colors or more (65536 colors or more recommended)

Mouse

A mouse that is compatible with Windows 7, Windows 8, Windows 8.1, and Windows 10.

2
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Installation and Uninstallation
Installation
1. Download the Mask Editor from YOKOGAWA Website. Download it to an arbitrary
location on your PC.

2. The downloaded file is compressed. Use an appropriate decompression software
to decompress the file. A folder named MaskEditor is created.

Start Procedure
1. Double-click MaskEditor.exe. The Mask Editor starts.
Uninstallation
1. Delete the entire MaskEditor folder.
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Setting the Environment for Creating Mask Patterns
Set the environment for creating mask patterns.
You can enable/disable the multi element function and set the unit of the coordinates
used to create the patterns.

1. From the Edit menu, choose Setting. The Settings dialog box opens.
2. If you are creating mask patterns using elements, select the Multi Element check
box.

					

Note

If you select the Multi Element check box, you must select the element for creating the center
pattern. For a description of the element setting, see page 10.

3. Set the unit of the coordinates used to create the mask pattern to Division or

Volt&Time. If you select Volt&Time, set the time/division of the time axis, the
voltage/division of the voltage axis, and the offset.

					

4. When you are finished specifying the settings, click OK. To cancel the settings,
click Cancel.

Setting the Snap-to-Grid Function
5. From the View menu, point to Snap. A menu appears for you to select the snap
position on the grid.

					

6. Select 0.1, 0.2, 0.5, or None.
0.1:
0.2:
0.5:
None:

4

Snap to any of the 10 divisions of the grid
Snap to any of the 5 divisions of the grid
Snap to any of the 2 divisions of the grid
Do not snap to the grid
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Creating Mask Patterns Using the Mouse
There are two methods for creating mask patterns, using the mouse or entering
coordinates numerically. This section explains the method for creating mask patterns
using the mouse.
To create mask patterns using elements, you must select the elements for which to
create patterns in advance. For a description of the element setting, see page 10.

1. If the window is not open, choose New from the File menu, or click

. A window

for creating patterns opens.

					

2. From the Edit menu, choose Create Polygon, or click

.

3. Click the vertices of the pattern on the coordinates. After you click the last vertex,
right-click. The vertices are connected with lines to create the pattern.
Set three or more vertices.

					

Note
•
•
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To delete a pattern that you created, choose Undo from the Edit menu, or click
.
To redo the operation that you undone, choose Redo from the Edit menu, or click
.
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Creating Mask Patterns Using the Mouse

Changing the Shape of a Pattern or Moving a Pattern
4. Click

on the toolbar.

5. To change the shape of a pattern, drag the vertex or line of the pattern. To move
the pattern, select the entire pattern and drag it.

Note

When the pointer is

, the vertex or line of the pattern can be dragged. When the pointer is

, the entire pattern can be moved.

Adding a Vertex
6. To add a vertex to a pattern that has been created, choose Segment from the
Edit menu, or click

.

7. Move the pointer to the position on the pattern line where you wish to add the

vertex. Click at the position where the pointer changes to a + cursor. A vertex is
added..

Expanding or Reducing the Pattern
8. To expand or reduce a pattern that has been created, choose Scale from the Edit
menu, or click

.

9. Move the pointer near a vertex or line on the pattern. Drag the position where the
pointer changes to

to expand or reduce the pattern.

Copying/Pasting a Pattern
10. Click the pattern to be copied, and choose Copy from the Edit menu or choose
Copy from the shortcut menu that appears by right-clicking the pattern to be
copied.

11. Choose Paste from the Edit menu, or choose Paste from the shortcut menu that
appears by right-clicking an arbitrary position on the coordinates.
The pattern is pasted at the clicked position.

Deleting a Pattern
12. After clicking the pattern to be deleted, choose Cut from the Edit menu, or click
on the toolbar. The selected pattern is deleted.

6
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Creating Mask Patterns Using the Mouse

Changing the Pattern Color
13. From the View menu, choose Color or click

. The Color dialog box opens.

					

14. Select a color and click OK.
If you carry out the operation above when a pattern is selected, the color of the
selected pattern changes.
If a pattern is not selected, the color is applied to the next pattern that you create.

Undoing/Redoing an Operation
To undo a previous operation, carry out any of the following procedures.
• From the Edit menu, choose Undo.
• Choose Undo from the shortcut menu that appears when you right-click.
• Click

.

To redo an operation that you undone, carry out any of the following procedures.
• From the Edit menu, choose Redo.
• Choose Redo from the shortcut menu that appears when you right-click.
• Click
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Creating Mask Patterns by Specifying Coordinates
This section explains the procedure of creating patterns by specifying the vertical and
horizontal coordinates, without using the mouse.

1. From the Edit menu, choose Create Polygon by Data. A Create Polygon dialog
box appears.

					

Delete the selected vertex
Add a vertex between the selected vertex
and the previous vertex

2. Double-click the vertical or horizontal input area, and enter the coordinate.
Enter at least three coordinates.

Note
•
•

The vertical and horizontal axes appear differently depending on the unit of coordinates.
For details on the unit of coordinates, see page ???.
The data number is automatically assigned.

3. Click Create. The pattern is created on the coordinates.
Click Cancel to clear the input data and not create the pattern.

Using Elements

To create mask patterns by using elements, select the element for which the pattern
is to be created in step 2 above. The same pattern can also be assigned to multiple
elements.

			

8
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Creating Mask Patterns by Specifying Coordinates

Editing an Existing Pattern by Specifying Coordinates

To edit an existing pattern, select the pattern, and choose Property from the Edit
menu or choose Property from the shortcut menu that appears by right-clicking the
coordinates. The Create Polygon dialog box shown above appears. Edit the pattern
using the dialog box.
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Using Elements
A mask pattern can be created for each element and combined to create a mask pattern.
This software program allows mask patterns to be created for up to four elements.
This section explains the procedures for displaying and locking a pattern that has been
created for an element and the procedures for selecting the element to be edited.

1. From the View menu, choose Element. The Element Setting dialog box opens.
Editable element

					

Show/Hide

Lock/Unlock

The menu does not appear when the multi element function is enabled. To enable
the multi element function, follow the procedures in "Setting the Environment for
Creating Mask Patterns" on page 4.

2. As necessary, click the Display (show/hide) and Lock (lock/unlock) option buttons
for each element.

If the Display option button is selected, the pattern of the element is displayed.
If the Lock option button is selected, the pattern of the element is locked and
cannot be edited.

3. To select the element to be edited, select the Active option button. When you

select the Active option button, the Display option button is also selected. The
Lock option button is also released.

4. Click OK to apply the specified settings.

10
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Saving/Loading the Mask Patterns
Mask patterns that you create can be saved, and mask patterns that you saved earlier
can be loaded.

Saving (Overwriting) the Mask Pattern
1. From the File menu, choose Save. The mask pattern is saved (overwritten)..
Saving the Mask Pattern by Assigning a Name
1. From the File menu, choose Save As, or click

on the toolbar. The Save As

dialog box opens.

					

2. Set the file name and destination and click Save.
Loading a Mask Pattern
1. From the File menu, choose Open, or click
box opens.

on the toolbar. The Open dialog

					

2. Set the directory in which the file is saved and the file name, and click Open. The
selected mask pattern is displayed.
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Printing the Mask Pattern
The mask patterns that you create can be printed.

1. From the File menu, choose Print, or click
box opens.

on the toolbar. The Print dialog

				

2. Set the necessary items, and click Print.
Showing the Preview
1. From the File menu, choose Print Preview, or click
preview is displayed.

on the toolbar. The print

Setting the Printer
1. From the File menu, choose Print Setup. The Print Setup dialog box opens.
2. Set the necessary items, and click OK.

12
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Arranging the Screen
This section explains the procedures for cascading or tiling windows when multiple
windows are open.

1. From the Window menu, choose Cascade or Tile.
		 Cascade

					

		 Tile
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